Delay in execution of Automation rules

Incident Report for Confluence

Resolved

Our teams have identified and fixed the root cause of the issue that caused delay in executing Automation rules. This was caused due to scaling issues following on from the recent AWS outage.
This issue is marked as resolved.
Posted Oct 22, 2025 - 06:47 UTC

Identified

Atlassian team has identified the cause of the issue that led to delay in execution of Automation rules. This is a follow-on effect of the recent AWS outage.
We shall keep you informed of the progress every hour, if not sooner.
Posted Oct 22, 2025 - 06:34 UTC

Investigating

We understand that our customers are experiencing delay in execution of Automation rules. While our team is investigating further on this, it looks like a follow-on effect of the recent AWS outage.
We continue to investigate further on this and we shall keep you informed of the progress every hour if not sooner.
Posted Oct 22, 2025 - 06:20 UTC
This incident affected: Confluence Automations.