Performance issues with Chrome 96 in Confluence editor
Incident Report for Confluence
Resolved
With the release of Chrome 97 (https://chromereleases.googleblog.com/2022/01/stable-channel-update-for-desktop.html), this issue has now been resolved.
Users of Chrome 97 and newer beta versions, along with other browsers based on Chromium 97 will no longer be affected by this issue.

If you are on an older version of Chrome, do upgrade to this version for the fix.
Posted Jan 18, 2022 - 00:22 UTC
Update
A bug in how chromium v96 (Chrome, Edge, Brave, …) does spellchecking causes the performance of the Editor experience to slow down. The performance impact will be relative to the size of the document and the number of words that are identified as misspelled by the chrome browser (red squiggle underline).

Chrome has fixed the issue in Chrome 97 which became available on Jan 4th and has now rolled out to ~60% of impacted Chrome users.
https://chromereleases.googleblog.com/2022/01/stable-channel-update-for-desktop.html
Posted Jan 13, 2022 - 03:29 UTC
Monitoring
A recent change to how chromium (Chrome, Edge, Brave, …) does spellchecking can cause the performance of the Editor experience to slow down.

The performance impact will be relative to the size of document and number of words which are identified as misspelt by the chrome browser (red squiggle underline).

As this performance issue is coming from the browsers built in spellchecking, Atlassian is limited in how we can mitigate the issue.

The current suggested workaround is to disable spellchecking on chrome://settings/languages, Downgrade Chrome, or use an alternate browser

Chrome have fixed the issue in Chrome 97 which is currently in Beta and due to become Stable on January 4th .

The chromium bug also has reports of this issue impacting other web based editors such as Dropbox, Notion and Wikipedia.
https://bugs.chromium.org/p/chromium/issues/detail?id=1271918
Posted Dec 16, 2021 - 01:21 UTC
This incident affected: Create and Edit.