Organization administrators can now receive personalized incident information in Atlassian Administration. Subscribe to System Health to receive notifications if a reliability incident affects your organization.
On June 16, 2026, Confluence Cloud users for some customers may have experienced performance degradation of view and edit page experiences. The issue has now been resolved, and the service is operating normally for all affected customers.
Posted Jun 16, 2026 - 15:56 UTC
Monitoring
We have been able to apply the fix to mitigate the issue and we are seeing recovery.
We continue to monitor the situation and should be fully recovered soon. We should be able to provide more updates in the next one hour or earlier.
Posted Jun 16, 2026 - 14:53 UTC
Identified
We have identified the source of degraded performance affecting some Confluence Cloud users. A subset of users may experience errors or slowness when viewing or editing pages.
Our team has initiated a remediation and is actively monitoring recovery. We will provide another update within one hour or once the issue is fully resolved.
Posted Jun 16, 2026 - 14:28 UTC
Investigating
Our team is investigating degraded performance affecting your service.
We are actively working to identify the cause and resolve the issue. We will provide further updates within one hour.
Posted Jun 16, 2026 - 13:46 UTC
This incident affected: View Content, Create and Edit, Comments, Authentication and User Management, Search, Administration, Notifications, Marketplace Apps, Purchasing & Licensing, Signup, Confluence Automations, Cloud to Cloud Migrations - Copy Product Data, Server to Cloud Migrations - Copy Product Data and Mobile (iOS App, Android App).