Confluence page load errors

Incident Report for Confluence

Postmortem

Summary

On Apr 15, 2025, between 14:29 and 14:55 UTC, some Atlassian customers in the EU central region using Confluence Cloud products encountered errors when viewing pages. The event was triggered by a temporarily spiked error on Confluence backend services due to a capacity issue. Our alerts detected the incident within 1 minute and the impact was mitigated by scaling up the backend service that was under load. This restored the Atlassian services to a fully operational state. The total time to resolution was approximately 26 minutes.

IMPACT

The impact was on Apr 15, 2025, between 14:29 and 14:55 UTC, to customers using Confluence Cloud. The incident caused service disruption to some EU central region customers, resulting in reduced functionality and limited access when loading Confluence pages, space overviews, and the home page.

ROOT CAUSE

The incident's root cause stemmed from one of Confluence's non-critical backend services not being fully scaled to accommodate an unusual spike in traffic. Although failures from this backend service shouldn't affect page views critically, it was treated as a severe failure, impacting the Confluence core experience in this incident.

REMEDIAL ACTION PLAN & NEXT STEPS

We fully understand that outages impact your productivity. We continuously evaluate and validate the capacity of our backend services that are critical to the Confluence user experience. However, the impact of this non-critical backend service on the Confluence page view functionality was not identified beforehand.

We are prioritizing the following improvement actions designed to avoid repeating this type of incident:

  • Reviewing the peak capacity allocated for critical backend services and ensuring that adequate capacity is reserved to encounter traffic spikes.
  • Introducing fallback mechanisms for failures from non-critical backend services to improve Confluence service resiliency.

We apologize to customers whose services were impacted by this incident. We are taking steps designed to improve the platform’s performance and availability.

Thanks,

Atlassian Customer Support

Posted 5 days ago. May 23, 2025 - 15:28 UTC

Resolved

Between 14:29 UTC to 14:55 UTC, some users may have experienced page load errors for Confluence. The issue has been resolved and the service is operating normally. Once we complete our internal incident review process, we will publish a more detailed postmortem of what went wrong, along with steps we're taking designed to prevent this from happening again in the future.
Posted 1 month ago. Apr 15, 2025 - 15:31 UTC

Investigating

Between 14:29 UTC to 14:55 UTC, some users may have experienced page load errors for Confluence. The issue has been resolved and the service is operating normally. Once we complete our internal incident review process, we will publish a more detailed postmortem of what went wrong, along with steps we're taking designed to prevent this from happening again in the future.
Posted 1 month ago. Apr 15, 2025 - 15:31 UTC
This incident affected: View Content.