Some documents are not appearing in confluence search results

Incident Report for Confluence

Resolved

This incident has been resolved.
Posted 7 months ago. Sep 14, 2024 - 04:15 UTC

Update

We are continuing to monitor for any further issues.
Posted 7 months ago. Sep 14, 2024 - 04:15 UTC

Monitoring

We have identified the root cause of the missing pages in search results and mitigated any further impact. However, some pages may still not show until the re-index is complete.

We are continuing to monitor this closely.
Posted 7 months ago. Sep 12, 2024 - 06:06 UTC

Identified

We have identified the issue and have turned off the faulty feature flag. The team will reindex affected documents to ensure they start appearing in search results.
Posted 7 months ago. Sep 11, 2024 - 11:06 UTC

Update

Update: We are actively investigating the issue where some documents are missing from search results because the permissions configuration is not being correctly passed to the downstream indexer, resulting in restrictive search outcomes.
Posted 7 months ago. Sep 11, 2024 - 08:30 UTC

Investigating

We are investigating reports of complete list of documents not appearing as part of Confluence Search results. We will provide more details once we identify the root cause.
Posted 7 months ago. Sep 11, 2024 - 07:24 UTC
This incident affected: Search.