Degraded performance with Confluence Cloud

Incident Report for Confluence

Resolved

On June 12th 2026, between 07:04 to 11:06 UTC, some Confluence users may have experienced service disruptions.

The issue has now been resolved and the service is operating normally for all affected customers.
Posted Jun 12, 2026 - 11:15 UTC

Identified

Our teams have identified the root cause of this issue and implemented a fix. We are beginning to observe signs of recovery, with some affected users regaining access to view, create, and edit content on Confluence Cloud.

We will provide a further update within one hour, or sooner if we confirm full recovery for all affected customers.
Posted Jun 12, 2026 - 10:29 UTC

Update

Users are experiencing degraded performance with view content, create and edit functionality on Confluence Cloud primarily in the EU region.

Our teams are actively working to identify the root cause of the issue. We will share additional updates in next 2 hours or sooner as more information is available.
Posted Jun 12, 2026 - 08:45 UTC

Investigating

Users are experiencing experiencing degraded performance in Confluence Cloud affecting view page and edit page functionality. Our teams are actively investigating and will be sharing more updates in next 1 hour or sooner.
Posted Jun 12, 2026 - 07:39 UTC
This incident affected: View Content and Create and Edit.