Confluence Cloud pages are not loading
Incident Report for Confluence
Resolved
Between 14:04 UTC to 14:23 UTC, some users experienced issues to load pages in Confluence Cloud. The issue has been resolved and the service is operating normally.
Posted Mar 24, 2020 - 15:01 UTC
Investigating
We are investigating reports of intermittent errors related to loading pages from Confluence Cloud customers. We will provide more details once we identify the root cause.
Posted Mar 24, 2020 - 14:32 UTC
This incident affected: View Content.