Confluence is not accessible via Microsoft Edge v17 and v16
Incident Report for Confluence
Resolved
We can confirm that there are no issues using Microsoft Edge v18, this is the latest version we support.
Please update your Microsoft Edge browser to v18 if you have any issues with Confluence Cloud access.
Posted 29 days ago. Sep 20, 2019 - 03:30 UTC
Investigating
We are investigating an issue where Confluence is not accessible via Microsoft Edge v17 browser.
We will provide more details within next hour.
Posted 29 days ago. Sep 20, 2019 - 01:26 UTC
This incident affected: View Content.